Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 15, 2024 - 00:00 GMT
Scheduled
We will be undergoing emergency maintenance during this window to apply vendor security updates. Multiple service interruptions of up to 5 minutes are planned during the work.
Posted Nov 08, 2024 - 10:16 GMT
This scheduled maintenance affected: Voice & Video (Hosted Mitel Telephony, SIP Lines, Odyssey Voice), Connectivity (ADSL/FTTC, Microwave), IT & Cloud (DNS, Email Hosting, Email Filtering, Shared Web Hosting, MPLS Core, Firewall as a Service, Odyssey Private Cloud), and Odyssey (Odyssey Service Team, Odyssey Systems Website).