Loss of Manchester Core Router

Incident Report for Odyssey Systems Limited

Update

Engineers are on site and have confirmed a hardware failure in the core router. All services remain operational on redundant equipment and are performing normally. Replacement hardware is expected on site within approximately four hours, after which engineers will carry out the swap. A brief service interruption is possible during replacement. Next update will be immediately prior to commencement of the replacement.
Posted Jun 06, 2026 - 15:59 BST

Update

Odyssey engineers are enroute to our Manchester datacentre. A further update will be provided by 21:00.
Posted Jun 06, 2026 - 14:41 BST

Update

We have confirmed a core router in our Manchester data centre has failed. Root cause is under investigation. All services remain operational thanks to network redundancy; however, resilience is reduced and service should be considered at risk until the fault is resolved. Next update by 15:00.
Posted Jun 06, 2026 - 12:21 BST

Identified

We believe an Odyssey owned and managed core router in Manchester is at fault. Engineers have taken steps to restore service while investigations are ongoing.
Posted Jun 06, 2026 - 11:59 BST

Investigating

We are investigating reports of loss of service from approximately 11:35 this morning
Posted Jun 06, 2026 - 11:35 BST
This incident affects: Connectivity (ADSL/FTTC, Microwave, Ethernet).