Impact due to storm Eowyn
Incident Report for Odyssey Systems Limited
Resolved
This incident has been resolved.
Posted Jan 24, 2025 - 21:25 GMT
Identified
We are aware of multiple service issues due to the impact of storm Eowyn.
Posted Jan 24, 2025 - 15:13 GMT
This incident affected: Voice & Video (Hosted Mitel Telephony, SIP Lines, Legacy Lines (Analogue/ISDN), Odyssey Voice), Connectivity (ADSL/FTTC, Microwave, Ethernet), IT & Cloud (DNS, Email Hosting, Email Filtering, Shared Web Hosting, MPLS Core, Firewall as a Service, Odyssey Private Cloud, Odyssey Desktop), and Odyssey (Odyssey Service Team, Odyssey Systems Website).