Call Quality
Incident Report for Odyssey Systems Limited
Resolved
This incident was confirmed to be a fault within BT infrastructure and is now resolved with no further issue.
Posted Apr 26, 2022 - 12:06 BST
Monitoring
Clients are reporting normal service. Our team are still working to identify root cause.
Posted Apr 25, 2022 - 12:16 BST
Investigating
We are receiving reports of call quality issues. These appear to be inbound from the BT network only. Our team are investigating.
Posted Apr 25, 2022 - 11:59 BST
This incident affected: Voice & Video (SIP Lines).