Intermittent Connectivity Issues

Incident Report for Odyssey Systems Limited

Update

We have observed further attack attempts using varying strategies from the bad actors. Our mitigations have held, and there has been no further impact to service.

We will keep this status page entry open for 24 hours of continued monitoring before closing it. Further updates will be posted here if anything changes.
Posted Jul 14, 2026 - 16:59 BST

Monitoring

We have been mitigating a distributed denial-of-service (DDoS) attack against our infrastructure. Over the past couple of hours this caused intermittent connectivity issues, including timeouts and slow responses for some users.

Our team has identified and mitigated the attack strategy, and service has been restored. We are continuing to monitor closely in case the attacker changes tactics, and are ready to respond quickly if they do.

This is an availability issue only, with no impact to customer data.
Posted Jul 14, 2026 - 14:59 BST
This incident affects: Connectivity (ADSL/FTTC, Microwave, Ethernet).